Apache Struts you're stuffed: Vuln allows hackers to inject evil code into biz servers

https://www.theregister.co.uk/2017/09/05/apache_struts_vuln/